Participate in SCR-485 Engineering Prototype

I would like to participate in this engineering prototype to control my electric hotwater heater, the element in this hotwater cylinder is 1KW as you can see from my IAM Meter screenshot below, running this day between approx 8:15am and 2:15pm.



This is currently triggered by an automation in homeassistant IAMMeter Modbus when consumption and generation has at least 1KW of free capacity that would normally be exported, reacting every 1 second. Example of this below. I installed a 1KW element in it so on cloudy days I could mostly heat hot water still, if I get this device I am willing to up this to 2.5KW element to make the most of self consumption over most of the day.



I already have monthly reporting in place which is emailed to myself, here is an example of my billing

Thread Status
73
309
3
10
0

Sort replies by:

please provide the spec of the resistive load, like this https://www.solahart.com.au/products/solar-water-heating/solahart-l-series/302l/


we need to confirm whether the load is compatible with SCR-485 (voltage and current are within the rating of SCR-485)

I would like to participate in this engineering prototype to control my electric hotwater heater, the element in this hotwater cylinder is 1KW as you can see from my IAM Meter screenshot below, running this day between approx 8:15am and 2:15pm.This is currently triggered by an automation in homeassistant IAMMeter Modbus when consumption and generation has at least 1KW of free capacity that would normally be exported, reacting every 1 second. Example of this below. I installed a 1KW element in it

The activity of the first batch sample testing will end soon. 

Looking forward to your further information.

Please find the label off the cylinder

The cylinder has a modified resistive load element, currently 1KW, as I mentioned to get the most from this system I am willing to replace this element with a 2.4KW element, as per this link

https://solarhotwaterparts.com.au/products/genuine-rheem-kit-element-sickle-2400w-150-050265k

I have sent an email, please check your mailbox.

Hi,


I have received the device thank you very much, I have powered the device on and joined it to my network, I still am trying to work out where to install the device, was bigger than I was expecting.

I have added the device to homeassistant. Except I feel like I am missing things for the setup.



Firstly prior to adding the device I created the scr-485.yaml file in the HA config directory, edited the IP address of my IAM Meter, and saved the file. Then added the device, as you can see above, however the grid power parts are showing no data?

I have created the SSID and password files in the config directory as well called from the scr-485.yaml file

I saw on another post that the device was added using add-ons section of home assistant, is this required? because I only have HA core so can't add addons.


This scr-485.yaml is used by esphome for your own DIY scr-485. If you don't need DIY, you don't need this, but all your automatic control needs ha to achieve. If you want to control it through the device itself, you need to recompile the esphome firmware. For details, please refer to the steps in https://imeter.club/topic/595. If your ha cannot install the esphome addon plug-in, you can refer to this post https://esphome.io/guides/installing_esphome to install it through windows. After the installation is complete, start it through esphome esphome_config/ dashboard, and then open http:127.0.0.1:6052

Hi,I have received the device thank you very much, I have powered the device on and joined it to my network, I still am trying to work out where to install the device, was bigger than I was expecting.I have added the device to homeassistant. Except I feel like I am missing things for the setup.Firstly prior to adding the device I created the scr-485.yaml file in the HA config directory, edited the IP address of my IAM Meter, and saved the file. Then added the device, as you can see above, howeve

Hi miwyf,

I am not sure, I think I am misunderstanding your post.

I have HA but core so no addons, is this required to get this working in HA?

My Environment;

My Home Assistant is running on a synology NAS within docker. 

My IAM Meter is installed in HA using HACS modbus deployment.


I can't work out what is required outside of installing python, wheel and esphome, because I do not see any command line references to do this via windows, am I supposed to use this to update the device with the yaml including my IamMeter IP?

I see mention in the topic you reference where you provided a .bin file with the config to firmware OTA update? The add this back to HA and have it talk back to my IAM Meter Modbus deployment there.

This scr-485.yaml is used by esphome for your own DIY scr-485. If you don't need DIY, you don't need this, but all your automatic control needs ha to achieve. If you want to control it through the device itself, you need to recompile the esphome firmware. For details, please refer to the steps in https://imeter.club/topic/595. If your ha cannot install the esphome addon plug-in, you can refer to this post https://esphome.io/guides/installing_esphome to install it through windows.

The use of esphome is only to recompile the firmware according to your own needs. Of course, if the current functions can fully meet your needs, you don't need to install esphome, and you can use homeassistant to achieve related automation. If you want to achieve more complex functions, such as automation on the scr-485 local, you need to use esphome to recompile and upgrade the firmware that suits you.

If you are using a synology NAS, you can install esphome using docker.


Hi miwyf,I am not sure, I think I am misunderstanding your post.I have HA but core so no addons, is this required to get this working in HA?My Environment;My Home Assistant is running on a synology NAS within docker. My IAM Meter is installed in HA using HACS modbus deployment.I can't work out what is required outside of installing python, wheel and esphome, because I do not see any command line references to do this via windows, am I supposed to use this to update the device with the

sudo docker run -d --name esphome --net=host -p 6052:6052 -p 6123:6123 -v /volume1/docker/home-assistant/esphome:/config esphome/esphome

The use of esphome is only to recompile the firmware according to your own needs. Of course, if the current functions can fully meet your needs, you don't need to install esphome, and you can use homeassistant to achieve related automation. If you want to achieve more complex functions, such as automation on the scr-485 local, you need to use esphome to recompile and upgrade the firmware that suits you.If you are using a synology NAS, you can install esphome using docker.

thanks for this.

I do not understand what you are trying to say about if it fully meets my needs?

I have the device added in HA, and it functions fine but does not show iammeter power details, that is all. How do I get this fixed in using just HA? so I do not need to reflash.

sudo docker run -d --name esphome --net=host -p 6052:6052 -p 6123:6123 -v /volume1/docker/home-assistant/esphome:/config esphome/esphome

Solution 1: Integrate the iammeter meter into homeassistant(https://www.iammeter.com/docs/homeassistant), and then control the scr-485 through ha automation.

Solution 2: Get the power directly from the iammeter (WEM3080/WEM3080T...) IP address through scr-485 to control the set power. This solution requires you to recompile the firmware using esphome.https://www.iammeter.com/newsshow/scr-auto-control

thanks for this.I do not understand what you are trying to say about if it fully meets my needs?I have the device added in HA, and it functions fine but does not show iammeter power details, that is all. How do I get this fixed in using just HA? so I do not need to reflash.

Perfect i have the device in HA as I showed in the screenshot above earlier 2024-06-03 11:21

This was my first attempt as per your readily available information added in HA as below



So the problem I have is that this device in home assistant and as you can see below sensor data is all zero, I tried adding the yaml in HA but get errors, it does not like !lamba in the code within the yaml, so I have no idea what I need to add into the configuration.yaml to get the device to get it's sensor data from the IAM Meter?


Solution 1: Integrate the iammeter meter into homeassistant(https://www.iammeter.com/docs/homeassistant), and then control the scr-485 through ha automation.Solution 2: Get the power directly from the iammeter (WEM3080/WEM3080T...) IP address through scr-485 to control the set power. This solution requires you to recompile the firmware using esphome.https://www.iammeter.com/newsshow/scr-auto-control

SCR-485.yaml is the configuration file of the ESPHOME firmware, not the configuration.yaml of Homeassistant

ESPHome is a system to control your ESP8266/ESP32 by simple yet powerful configuration files.

Home Assistant is a open source home automation that puts local control and privacy first. 

ESPHome and Home Assistant are two completely different things. Why do you think that you are using the ESPHome yaml configuration file in Home Assistant?

Perfect i have the device in HA as I showed in the screenshot above earlier 2024-06-03 11:21This was my first attempt as per your readily available information added in HA as belowSo the problem I have is that this device in home assistant and as you can see below sensor data is all zero, I tried adding the yaml in HA but get errors, it does not like !lamba in the code within the yaml, so I have no idea what I need to add into the configuration.yaml to get the device to get it's sensor data

https://community.home-assistant.io/t/esp32-scr-module-linearly-adjust-the-power-output-of-resistive-loads-such-as-heaters/726575

This is a routine that manually controls the SCR-485 through Homeassistant. If you want to control the SCR-485 through Grid Power, then you need homeassistant Automations

Nevermind

https://community.home-assistant.io/t/esp32-scr-module-linearly-adjust-the-power-output-of-resistive-loads-such-as-heaters/726575This is a routine that manually controls the SCR-485 through Homeassistant. If you want to control the SCR-485 through Grid Power, then you need homeassistant Automations

So I have built the device using the esphome docker container and can see many changes with the latest yaml now in HA, for anyone else deploying this is defaults to auto battery mode and looks like it is not working, you need to turn off 3 with battery and turn on 3 auto mode switch, then the Grid information comes through from you yaml edit during the install.

This is a step-by-step tutorial about how to use ESPhome to configure SCR-485

https://www.iammeter.com/newsshow/quickstart-scr485

So I have built the device using the esphome docker container and can see many changes with the latest yaml now in HA, for anyone else deploying this is defaults to auto battery mode and looks like it is not working, you need to turn off 3 with battery and turn on 3 auto mode switch, then the Grid information comes through from you yaml edit during the install.

The definition of the previous code on the With Battery switch may have some deviations in understanding. The latest code has been changed to With Battery Set: Indicates if the system has a Battery. Attery Power.
The latest code is changed to if you do not have a battery, you can use SCR-485 Local automatic control:
3 Auto Mode Switch: 'On',
4 With Battery: 'OFF'


https://github.com/lewei50/Solar-PV-Monitoring/blob/master/ESPHome/scr-485.yaml

So I have built the device using the esphome docker container and can see many changes with the latest yaml now in HA, for anyone else deploying this is defaults to auto battery mode and looks like it is not working, you need to turn off 3 with battery and turn on 3 auto mode switch, then the Grid information comes through from you yaml edit during the install.

This is the control logic for the latest YAML .

If you do not have battery , please keep the option of "with battery" off(default value).

automation_scr_grid_power

So I now have the device installed and working.

Had an issue initially as it was reading the wrong CT, so I fixed it and reinstalled the SCR-485, the parts above the generation was me manually setting it. It took a little time to settle down then was very good at following the gen power curve, as shown below.




Will be great to see tomorrow how this looks

I did switch it to auto once it worked, only did once I recompiled changing the CT clamp being.

I have discovered an issue, at some point over night, the device has switched to 3 With Battery by itself, therefore it was not working today. I have manually switched it this morning to 3 Auto Mode Switch, however the device appears to have locked up, no grid data.


I have completed a restart and the device auto switches to Battery mode, switching to 3 Auto Mode Switch, and the grid data is still not coming back, not sure what could be wrong.

Please try the auto mode , which would be a more fantastic effect.https://www.iammeter.com/newsshow/quickstart-scr485#example-2-controlling-boiler-heater-power-based-on-grid-power

Restarting the device multiple attempts it did not recover, I had to switch off the breaker switch for about 5 seconds then power it back on before it recovered.

Here you can see it in live action, once the scr-485 was fully powered down and started again



The device switched to battery again, i was wondering why it didn't start heating again after having showers.

I had to turn this battery mode off and switch on 3 Auto Mode Switch for it to start again.

Can you please provide the steps to remove this battery mode, and especially to be the default for people without batteries?

Have you updated the yaml to the latest? 

If not ,please upgrade it now.

Then the default status of the "with battery " would be "off"

  1. Please update to the latest version of the YAML firstly.

  2. Even if the 'with battery' option is enabled, it will not be effective unless you correctly configure the IP address of the meter monitoring the battery power in the YAML.

In response to your points

1. Thank you I will update the yaml

2. I really don't understand your comments quite often and who or what they are directed at. Of course the meter was set correctly otherwise it wouldn't be working right? you saw this post 2024-06-08 07:21? It becomes confusing because it seems like you are telling me I have it setup wrong.

The device today did not experience the same issues as yesterday, it continued to work and run as expected as soon as the generation surpassed the consumption, I did knock back the threshold to -30 because early in the morning at -20 was still using a little power from the grid.




Please update to the latest version of the YAML firstly.Even if the 'with battery' option is enabled, it will not be effective unless you correctly configure the IP address of the meter monitoring the battery power in the YAML.

2. I really don't understand your comments quite often and who or what they are directed at. Of course the meter was set correctly otherwise it wouldn't be working right? you saw this post 2024-06-08 07:21? It becomes confusing because it seems like you are telling me I have it setup wrong.

"Due to limitations highlighted in this discussion, ESPHome cannot save boolean parameters. Consequently, the 'with battery' and 'auto mode switch' options reset to their default values after the SCR-485 is reset. Previously, the YAML configuration set 'with battery' to true by default. This meant that even if you manually disabled this option, it would revert to 'true' upon any reset of the SCR-485.

I want to clarify that even if 'with battery' is automatically set to true after a reset, it will not be effective unless the corresponding IP is correctly configured.

It’s important to note that the default value for 'with battery' has been changed to false in the latest YAML version."

In response to your points1. Thank you I will update the yaml2. I really don't understand your comments quite often and who or what they are directed at. Of course the meter was set correctly otherwise it wouldn't be working right? you saw this post 2024-06-08 07:21? It becomes confusing because it seems like you are telling me I have it setup wrong.The device today did not experience the same issues as yesterday, it continued to work and run as expected as soon as the generation surpassed

Additionally, the 'auto mode switch' value is currently set to 'false' in the latest YAML configuration. 

This can pose an issue if the SCR-485 resets unexpectedly, as it would disable the 'auto mode' after the reset. 

Therefore, we recommend setting the default value of the 'auto mode switch' to 'true', as discussed in this topic.

https://imeter.club/topic/604

 It is also important to configure the correct 'start time' and 'stop time' for the automation cycle.

Ok, so everything is working fine and as expected now.

What do you need from us now? When and how often would you like the reports?

We have a cloudy day today and this SCR-485 is going crazy not controlling the hot water heating at all, also causing substantial imports from the grid as below. I have tried to adjust the the interval setting even down to 1 second, which didn't seem to help. It seems to have settled down a bit and got back into sync again, I can only guess that the sun is more consistent.


Settings of the device

Here is broken down to 1second refresh, and as you can see a number of grid imports, and exports.

I have also noted today it appears that this device has not detected the thermostat switching off the power. I am not sure if it is supposed to do this or not? It has just set the output to the max power, as below, from the chart you can see that the hot water switched off at about 12:30pm



yesterday it stopped setting the power at 11:17 am

Which matches when the thermostat cut in yesterday, as below

Today it is still trying to set the power as below


12:10pm is where the hot water switched off via the thermostat.


Hi:

Why is the set power consistently zero during this period, as indicated in the red rectangle? Even if the thermostat cuts power to the boiler's heater, the set power would still fluctuate corresponding to variations in the grid power.

because of this?

Hi:Why is the set power consistently zero during this period, as indicated in the red rectangle? Even if the thermostat cuts power to the boiler's heater, the set power would still fluctuate corresponding to variations in the grid power.

Apart from what I have just written above, I have no idea why it would do this. All I am reporting is a difference to the day before, and differences to all days prior to installing the latest yaml yesterday.

I can explain why there is no data after 2:30pm yesterday this is because the switch was manually turned off by accident which was switched back on about 7:30am today.

Here are the previous days, this was the day the device was installed 7 June switched to zero until the next day from 3:44pm


8 June switched to 0 at 3:46pm, this time I can see actually co-insides at exactly the time where the generation is equal or less than the consumption.



So if this is the expected behaviour then that is fine, that was what I was trying to understand. I reported it because it was different than what I had previously noted, isn't this is what this testing is for?

I also don't want to do damage to the device if it is doing something that it is not supposed to be.

Thank you for providing the detailed information. Yes, that is exactly the purpose of our experiment. We organized this activity to use the power curve information provided by customers to help us analyze whether the operations performed by the SCR-485 are reasonable, so as to further upgrade the functionality of the SCR-485.

As you described below.

8 June switched to 0 at 3:46 pm

Could you please also provide the grid power status at these corresponding time (3:46pm at June 8th,)?

If the grid power is also close to zero at that time, then it can be reasonably explained as below.

If the grid power is also close to zero, it indicates that other loads are using the solar surplus at that time, leaving insufficient surplus to supply the heater. Consequently, the set power will be zero. Furthermore, the auto switch mode is disabled after 4pm, which means the set power remains at zero after 4pm until the next automatic cycle starts (after 7am the following day).


By the way, this is the latest version of the YAML now. Please upgrade it.

https://github.com/lewei50/Solar-PV-Monitoring/blob/master/ESPHome/scr-485.yaml

There was a bug in the previous YAML configuration. When outside the automatic cycle, the set_power remained at the last set value, which could cause issues. For example, if set_power was set to zero, the boiler's heater would not function until the next automatic cycle began.

A significant upgrade has been implemented in the latest YAML version. Now, after exiting the auto switch mode, the set_power will revert to maximum power instead of maintaining the last set value from the automatic switch cycle (such as the zero power value on June 8th). These upgrades ensure that the heater returns to thermostat control after leaving the automatic cycle.

Apart from what I have just written above, I have no idea why it would do this. All I am reporting is a difference to the day before, and differences to all days prior to installing the latest yaml yesterday.I can explain why there is no data after 2:30pm yesterday this is because the switch was manually turned off by accident which was switched back on about 7:30am today.Here are the previous days, this was the day the device was installed 7 June switched to zero until the next day from 3:

I have just looked at this device now and the power was set to 2.4KW still at 6pm and it was very dark here as below



I had the device to switch to off at 4pm, I think this caused it to stay online until now, I just manually set the off time to 6pm and toggled the 3 Auto Mode Switch, you can just see at the end of the graph that the set power has now gone to zero. I set it like this to be the same as recommended in you setup post as below.

I will update the yaml because I believe this was the issue I was seeing.

And in answer to your question above, yes the consumption on the 8th also was greater or equal to the generation

I have updated to the latest YAML

1. The behaviour for this was different it seemed to remember the last WIFI connection settings.

2. It appeared that it didn't restart after the firmware update, and I was able to reproduce the stuck set_power issue.

3. I fully powered down the device and started it again, and now I couldn't reproduce the set_power issue, so assume it has updated.

Can I suggest that we write a version number to the scr-485 page, so we know what build we are running?

Hi

As I have introduced in previous replies, the set_power would be resumed to the maximum power when it quit the "automatic switch mode" in the latest YAML.
And the reason is explained as below.


You can understand it this way: when 'automatic switch mode' is enabled, the set_power is controlled in real-time based on the solar surplus during the period between the start time and end time. When outside this time frame, the set_power reverts to max power, as if the SCR-485 device does not exist.


Over night the device remained on, the auto switch was on. 8am came when it was supposed to switch on, auto ended up switched off and when switching it back on, the device appears to have hung.


After turning the device auto mode back on, it just set the set_power to max with no reading data from the Grid, as below


Showing that it did in fact set the power to max

 

Hard power off and back on, it has now recovered.


I found that the time you posted showed 6:24. Does it correspond to the time on your side which is 8:24? Then I need to confirm that the device scr-485 did not get grid power for 20 minutes from 8:00 to 8:24.

Over night the device remained on, the auto switch was on. 8am came when it was supposed to switch on, auto ended up switched off and when switching it back on, the device appears to have hung.After turning the device auto mode back on, it just set the set_power to max with no reading data from the Grid, as belowShowing that it did in fact set the power to max 

summarize your issue, please let me know whether the summary below are correct.
1 the "auto mode" does not turn on automatically when it is after 8 am (start time)
2 when you turn on the "auto mode switch" manually, the grid power is always not displayed and the set_power keeps on the maximum power in around 20 mins.

Please also let me know,whether the scr-485 is accessible before you power reset it(I guess you have visited the web page and it open successfully ,but I need to confirm again)

Over night the device remained on, the auto switch was on. 8am came when it was supposed to switch on, auto ended up switched off and when switching it back on, the device appears to have hung.After turning the device auto mode back on, it just set the set_power to max with no reading data from the Grid, as belowShowing that it did in fact set the power to max 

'Over night the device remained on, the auto switch was on. 8am came when it was supposed to switch on, auto ended up switched off and when switching it back on, the device appears to have hung.'

Regarding this issue, it should be because you set the timezone to Asia/Shanghai. Just block servers and timezone. 

like this

Over night the device remained on, the auto switch was on. 8am came when it was supposed to switch on, auto ended up switched off and when switching it back on, the device appears to have hung.After turning the device auto mode back on, it just set the set_power to max with no reading data from the Grid, as belowShowing that it did in fact set the power to max 

1. I was watching the device through the web page prior to 8am, and auto mode was set, no grid data but this is expected with the start time and end times set.

1a. My device was set with the start time as 8am, as soon as 8am came the device either rebooted for what ever reason, or caused an exception that caused the auto mode switch to toggle to the off state. The power state of the device remained on.

1b. I went back to the web portal of the scr-485 and toggled the auto mode switch, and it put set_power at max 2.4KW, and the Grid power readings were N/A as per the diagrams in post above 2024-06-11 06:24. See graph below, red arrow is me toggling the auto mode switch. Green arrow is me hard powering off the scr-485 with a switch, powering it back on allows the device to operate as normal after about 8:30am.



Here is the state of power to the  scr-485



1. From above is me Turning the device back on after turning it off straight after conducting the new yaml build update to the device, as it appeared that the device was not working as expected because the set_power went straight to 2.4KW. This recovered after turning off and on.

2. Me turning off the device at 8:26am attempting to fix the issue reported top of post, no set_power auto adjustment due to no grid data.

3. Me turning the scr-485 back on, the toggling the auto mode switch to on, and the scr-485 working then as expected

So you can see from this the state of power to the device, was on the entire time between the times explained above.

Hope this helps

Looks like you are new here. Register for free, learn and contribute.