how to config 2 units of single phase iammeter into Home Assistant

Hi

I follow the link

https://www.iammeter.com/docs/homeassistant

I added the configuration.yaml config as below

sensor:

  - platform: iammeter

    host: 192.168.1.84

    name: loadcenter

Result: It is working fine but for my case I have 2nd unit too. then I try to add like this 

sensor:

  - platform: iammeter

    host: 192.168.1.84

    name: loadcenter    

 - platform: iammeter

    host: 192.168.1.25

    name: aircondition

Result: HA detected only one unit (load center).


Please advise how to change configuration.yaml so that the 2 units can be found and show correctly in the HA ?

2nd for the Dashboard, I may have to add loadcenter + aircondition to be total energy for my home, how to combine 2 values (two meters) to show one total number (I,w,kwh) and V are the same for 2 units. 

Thank you

Best regards,

Thread Status
6
65
3
0
0

Sort replies by:

What is the version of your homeassistant? I used the same configuration of 2022.5.2 and found no problems

HiI follow the linkhttps://www.iammeter.com/docs/homeassistantI added the configuration.yaml config as belowsensor:  - platform: iammeter    host: 192.168.1.84    name: loadcenterResult: It is working fine but for my case I have 2nd unit too. then I try to add like this sensor:  - platform: iammeter    host: 192.168.1.84    name: loadcenter     - platform: iammeter    host: 192.168.1.25





Home Assistant Core 2022.6.7

Home Assistant Supervisor 2022.05.3

Home Assistant OS 8.2

I just also upgraded homeassistant core to 6.7
With the following configuration, all meters can be identified

If you still can't get through the above settings, then you can use the following alternative configuration methods


  - platform: rest
  name: meter
  json_attributes:
    - mac
    - version
    - server
    - SN
    - Data
  resource: http://192.168.15.33/monitorjson
  method: GET
  username: admin
  password: admin
  authentication: basic
  #value_template: '{{ value_json.SN }}'    
- platform: template
  sensors:
    meter_voltage:
      unit_of_measurement: 'V'
      value_template: "{{ states.sensor.meter.attributes.Data[0] }}"
    meter_current:
      unit_of_measurement: 'A'
      value_template: "{{ states.sensor.meter.attributes.Data[1] }}"  
    meter_power:
      unit_of_measurement: 'W'
      value_template: "{{ states.sensor.meter.attributes.Data[2] }}"  
    meter_importenergy:
      unit_of_measurement: 'kWh'
      value_template: "{{ states.sensor.meter.attributes.Data[3] }}"  
    meter_exportgrid:
      unit_of_measurement: 'kWh'
      value_template: "{{ states.sensor.meter.attributes.Data[4] }}"

Home Assistant Core 2022.6.7Home Assistant Supervisor 2022.05.3Home Assistant OS 8.2

Hi, I can not get success connect, I checked firmware is PM_20180919_3162_1.

Shall I update new firmware ? 

This is the oldest version product named WEM3162 ,this product is not produced since 2018.

After 2018, we only provide the product of WEM3080 Series.

All upgrading is about the product of WEM3080 and WEM3080T

Hi, I can not get success connect, I checked firmware is PM_20180919_3162_1.Shall I update new firmware ? 
Looks like you are new here. Register for free, learn and contribute.