SCR-485 results (Queensland, Australia)

Here are my results based on my system and geographical location (south east corner of Queensland, Australia).

I've been testing for about a week now, modifying the code on the unit as the updates have come through, currently this is v1.1.6 firmware on the device.  I'm heating the household hot water via a 3.6kW resistive element in a commercially available hot water system.

This is our dry/sunny season here now and as I have a 30kW system and mainly clear skies it's been difficult to get any graphs to actually show the unit working because I have just so much production. This graph shows what I mean, here's a sunny winter's day.

That's left me with early mornings and late afternoons.  This also means that my cost analysis graphs won't show any real savings because I'd normally run the hot water between 10am to 2pm when I'm generally far exceeding my loads with production.  Some days my self use will only be 25% with the rest being sent to the grid.  It will be interesting when we get our next heavily overcast day.

Here's our data from today, I've marked when the HWS was enabled.  It was left on until sunset.

Here's the data from the HWS circuit

Daily Billing and saving report, notice the self use rate goes up when I turn on the HWS

Monthly Report

I do have issues with the device rebooting/restarting usually around every 15 minutes or less.  When it restarts, it's missing from action for about 5 or 6 seconds.  Normally you might not be aware of it other than in home assistant you can see the device switch's (scr_485_3_auto_mode_switch as an example) last_changed time resets to '0' and the SCR-485 web management page becomes unavailable.  I've also made some Home assistant automations and scripts that can drive the regulation, and I notice that when I opt for this (my) method, the device does not ever restart.  That being said, the purpose here is to test the device with its factory code and functionality, and to that effect I present the above.

To the developers, if you need more detail, please let me know.  I'll keep updating here with new graphs if I can generate one with more interesting data.  Here's hoping for a cloudy day! 😎


Thread Status
17
122
3
4
2

Sort replies by:

Hello, we have noticed that esphome 2024.6.0 and subsequent new versions have fixed the http_request bug. Since it has modified the configuration variables, we will modify scr-485.yaml accordingly and test it. It is expected that scr-485-new.yaml 1.2.1 will be released tomorrow. After the release, we will post the corresponding download link here as soon as possible

The latest ESPHOME update is here for home assistant.Is it possible this could fix this HTTP issue you mentioned aboveAm I safe to apply this update, and then do I re-compile/send again?Many thanksGreg

Thanks Greg.

Yes, as we discussed in another thread, your photovoltaic system is quite luxurious, with a 30kW power generation capacity and a battery storage system. Theoretically, devices like the SCR-485, which adjust power based on photovoltaic surplus, are used when there is no storage system. If you have a storage system, its effectiveness is significantly reduced.

"I do have issues with the device rebooting/restarting usually around every 15 minutes or less.  When it restarts, it's missing from action for about 5 or 6 seconds.  Normally you might not be aware of it other than in home assistant you can see the device switch's (scr_485_3_auto_mode_switch as an example) last_changed time resets to '0' and the SCR-485 web management page becomes unavailable.  I've also made some Home assistant automations and scripts that can drive the regulation, and I notice that when I opt for this (my) method, the device does not ever restart."

Could you give me the snapshot of the ESPHome`s webpage?

Please check whether the 'with battery' or 'auto switch mode' option is enabled while the IP address for the battery meter or grid meter is not set correctly. 


Here are my results based on my system and geographical location (south east corner of Queensland, Australia).I've been testing for about a week now, modifying the code on the unit as the updates have come through, currently this is v1.1.6 firmware on the device.  I'm heating the household hot water via a 3.6kW resistive element in a commercially available hot water system.This is our dry/sunny season here now and as I have a 30kW system and mainly clear skies it's been difficult to get any

Hi.  Yes it all appears to be working correctly up until it isn't.  It's definitely getting data from the local API because you can see from above it follows the production curve quite well despite the reboots.  the values being received to the web page correspond to what I see in Home Assistant.




When the device reboots/restarts you don't find the evidence of reboot on the SCR web management page unless you try and refresh the page while it's out, but in HA, you see this for the '3_auto_mode_switch'

https://www.youtube.com/watch?v=kHuaD2i3H-k

Thanks Greg.Yes, as we discussed in another thread, your photovoltaic system is quite luxurious, with a 30kW power generation capacity and a battery storage system. Theoretically, devices like the SCR-485, which adjust power based on photovoltaic surplus, are used when there is no storage system. If you have a storage system, its effectiveness is significantly reduced."I do have issues with the device rebooting/restarting usually around every 15 minutes or less.  When it restarts, it's miss

"Please disable the option of 'with battery' 

and check if the cycle reboot issue still persists."

yes, it persists with the battery option turned off, in fact it was rebooting prior to the battery option being available in the code

"Please disable the option of 'with battery' and check if the cycle reboot issue still persists."

 I've also made some Home assistant automations and scripts that can drive the regulation, and I notice that when I opt for this (my) method, the device does not ever restart.


Could you clarify the difference between running the device through Home Assistant automation versus using ESPHome in standalone mode?

When controlled via Home Assistant, are both "with battery" and "auto switch mode" disabled? If so, does disabling these options prevent the device from restarting every 15 minutes?

yes, it persists with the battery option turned off, in fact it was rebooting prior to the battery option being available in the code

yes absolutely, if set like this



the device does not restart if idle and also does not restart when Home Assistant controls it

 I've also made some Home assistant automations and scripts that can drive the regulation, and I notice that when I opt for this (my) method, the device does not ever restart.Could you clarify the difference between running the device through Home Assistant automation versus using ESPHome in standalone mode?When controlled via Home Assistant, are both "with battery" and "auto switch mode" disabled? If so, does disabling these options prevent the device from restarting every 15 minutes?

My colleague informed me that the periodic reboot is due to a bug in the HTTP request method in ESPHome. Although there has been significant feedback on this issue, it has not yet been resolved by the ESPHome team.

If you disable both "with battery" and "auto switch mode," the firmware of ESPHome will no longer perform HTTP requests, which should stop the reboots.


Ok, so for now, are you happy for me to drive the functionality of the meter with Home Assistant automations?

My colleague informed me that the periodic reboot is due to a bug in the HTTP request method in ESPHome. Although there has been significant feedback on this issue, it has not yet been resolved by the ESPHome team.If you disable both "with battery" and "auto switch mode," the firmware of ESPHome will no longer perform HTTP requests, which should stop the reboots.

Yes, you can control it with Home Assistant. We are currently working on a method to estimate the benefits of introducing the SCR-485, but we have not yet found a reliable approach

This is what I try to achieve within automations from home assistant.  The automation looks at grid flow, battery flow and Hot water system flow and tries to keep about 500w of overhead available to the battery charging (or export if the battery is full).  WEMs are polled every 6 seconds via Local LAN API, faster polling would create more stable responses but I don't think the API can be polled faster using this method, so this is also why I choose to use a few hundred watts overhead so there's some buffer if the calculations are playing catch-up as other loads switch on and off or solar production varies.

Template example
{{ (states('input_number.real_hws_power_in_watts')|float - states('sensor.iammeter_api_battery_corrected')|float - states('input_number.iammeter_api_grid_corrected')|float-400)}}


Yes, you can control it with Home Assistant. We are currently working on a method to estimate the benefits of introducing the SCR-485, but we have not yet found a reliable approach

The latest ESPHOME update is here for home assistant.

Is it possible this could fix this HTTP issue you mentioned above



Am I safe to apply this update, and then do I re-compile/send again?


Many thanks
Greg

Yes, you can control it with Home Assistant. We are currently working on a method to estimate the benefits of introducing the SCR-485, but we have not yet found a reliable approach

If your esphome is a version before 2024.6.0, please use scr-485.yaml(version: "1.1.6").

If your esphome is version 2024.6.0 or later, please use scr-485-new.yaml(version: "1.2.1" or later).

The latest ESPHOME update is here for home assistant.Is it possible this could fix this HTTP issue you mentioned aboveAm I safe to apply this update, and then do I re-compile/send again?Many thanksGreg

Very nice, thank you!!

I applied the ESPHome Update and then applied the new Yaml.

It's night time here so can't actively test, but the device seems stable.
One thing to note, this  error occurred during sending the code to the device


and I think it's because there's no value set to be returned if the condition is false 

Snippet


possible solution??



Thanks for the continuing work and support

Regards
Greg

If your esphome is a version before 2024.6.0, please use scr-485.yaml(version: "1.1.6").If your esphome is version 2024.6.0 or later, please use scr-485-new.yaml(version: "1.2.1" or later).

Yes, your solution is correct, thank you very much for your correction.

I modified a few places.

Looks like you are new here. Register for free, learn and contribute.