Connection to Access Point Issues

I have been attempting to add the IAMMeter monitor to my Unifi AP.

I log in locally in the phone app while connected to IAMMeter WIFI, then try to set the AP to my Unifi AP, after doing this it disappears completely from my network and goes offline, does not appear to obtain a dhcp IP lease.

Then I have to go through the process again to attempt to get it working, if I choose my samsung smartthings hub it can connect to this and work.

There is nothing in my network config that blocks any DHCP leases, and have not had any problem with any other IoT devices obtaining DHCP leases through the Unifi AP.

Has anyone seen the similar issue and been able to resolve it, because I want to get this device off my smartthings hub, which obtains it's DHCP config from the Unifi dream machine pro.

Two SSID's are 2.4GHz only and it does not connect to these, the primary network supports 2.4 to 6GHz networks and does not connect to this one either.

Primary network settings - Note this also didn't work with 6GHz off and WPA2-3 and PMF optional or off.

2.4, 5, and 6GHz

802.11 DTIM Period - Auto - as recommended by Unifi

Minimum data rate control - Auto

WPA3

Both other SSIDs

2.4GHz Only

802.11 DTIM Period - Auto - as recommended by Unifi

Minimum data rate control - Auto

WPA2

PMF Optional or Off.

Thread Status
9
198
2
1
0

Sort replies by:

Hi:

after doing this it disappears completely from my network and goes offline, does not appear to obtain a dhcp IP lease.

When the energy meter is in this mode, Please help us to confirm
1 whether the WiFi LED is on?
2 how do you know that the DHCP server does not allocate the IP to the device? Have you reviewed all the local IPs and do not find the Mac of the energy meter? or by other methods?


The energy meter can only work in 2.4G/WPA2 now.

Yes I have monitored the mac to see if it showed up somewhere else, it just shows offline. And no other IP is allocated. I have even removed it completely from the DHCP server and tried to add it again, same issue no IP

Does the Meter support VLANs? If not this could explain that it wouldn't add to my IoT SSID

If an AP is in Mixed Band mode 2.4 to 5GHz and WPA2/WPA3 mode, I assume that the IAMMeter would negotiate 2.4GHz and WPA2?

From the Smartthings WIFI, it is the same DHCP server handing out the IP address for this.

Thank you will try this again tonight, from memory the light goes out and the device goes back into AP config mode after the save and reboot, eg it starts broadcasting its SSID for local connection.


So I have come home and confirmed that the WIFI light will not come on when attempting to add the meter to ANY SSID on my unifi AP, or my synology rt2600AC, each time the SSID shows up in the config screen, DHCP enabled (doesn't work either manually setting) Current IP/netmask gate gateway IP all show 0.0.0.0 and DNS Server 255.255.255.255.

Have to factory reset the monitor in order to change this. 

Again only WIFI it will connect to is the smartthings hub for whatever reason

Does the Meter support VLANs? If not this could explain that it wouldn't add to my IoT SSID


Hi, as far as I know, there is no extra need for the device to support VLAN.
The VLAN is a security feature of the switch with regard to layer 2.
it would subdivide the broadcast area of layer 2, only Mac in the same VLAN would receive the broadcast packet.
The device does not need the device to do anything in this process.
You just need to allocate the Mac to VLANs from the switch side.
Then the switch may add different vlanID for different Macs in the 2-layer switch process, and only the Macs with the same VLAN ID would think in the same LAN(VLAN).
But all of this is operated by the 2 layer switch ,has nothing to do the device.

According to your description, please check whether there is some setting in your IOT SSID, it may ask all of the MAC should be added in one of the VLANs.
If you do not add the Mac of the energy meter in the corresponding VLAN, it would not connect to the AP.


Thank you so much for the detailed response, it helped me understand one thing a little better.

Some devices must be tagged vlans, some must be untagged. I am guessing from your response that it doesn't matter so long as the vlan(s) are applied to the switch port profile.

So this still doesn't help me, because Main network does not have vlan it is just the default network same as the smartthings hub.

I only actually asked the VLAN question to mitigate why with a VLANed SSID with the most basic settings (specifically configured for IoT devices (generally pretty basic turn everything off and insecure settings)), and a VLAN port profile applied to the port and the IAMMeter device still won't connect and get an IP address.

IoT SSID automatically sets devices to VLAN 10 , all other IoT devices set the SSID and save and all good they obtain an IP via DHCP, and for good measure I fix and the ip address to the mac address.

Does the Meter support VLANs? If not this could explain that it wouldn't add to my IoT SSIDHi, as far as I know, there is no extra need for the device to support VLAN.The VLAN is a security feature of the switch with regard to layer 2.it would subdivide the broadcast area of layer 2, only Mac in the same VLAN would receive the broadcast packet.The device does not need the device to do anything in this process.You just need to allocate the Mac to VLANs from the switch side.Then the switch may add

So an update on this, I had to turn off 40MHz on the 2.4GHz band, so now only running 20MHz. Now I could add the IAMMeter device to the IoT network on Unifi dream machine pro.


Hi: I just check and found we always use the 40Mhz bandwidth in 2.4Ghz,  and it always works properly.

For me turning on 20MHz only with Unifi devices was the only way I could get the IAMMeter device to join the any SSID, each other time the module never enabled the WIFI (light not on) and no IP assigned.


Good to know now that I can turn this back on for my WIFI 6 devices.

Further update for anyone in the same situation, enabling 40MHz after IAMMeter has been joined to the SSID, it is still working as expected.

Looks like you are new here. Register for free, learn and contribute.