Hello am trying to connect to Iamameter MQQT broker but no data am receiving.

Thread Status
7
191
2
0
0

Sort replies by:

please let me know

 how do you configure your device (need snapshot)

Hello find attached

MQTT_BROKER = "mqtt.iammeter.com"

MQTT_PORT = 1883

MQTT_USERNAME = "meter_002"

MQTT_PASSWORD = "xxxxxxx"

MQTT_TOPIC = "device/xxxxx/realtime"

If you use the IAMMETER broker for testing, you just need to configure the energy meter run mode and TCP address like below

https://www.iammeter.com/docs/integrate-with-mqtt-server#2-upload-to-third-party-mqtt-server


I do not know why you need to set these

"MQTT_USERNAME = "meter_002"

MQTT_PASSWORD = "xxxxxxx"


MQTT_TOPIC = "device/xxxxx/realtime""


Please give me the snapshot of your setting, not just the word description.

Hello find attachedMQTT_BROKER = "mqtt.iammeter.com"MQTT_PORT = 1883MQTT_USERNAME = "meter_002"MQTT_PASSWORD = "xxxxxxx"MQTT_TOPIC = "device/xxxxx/realtime"

THE IAMAMETER cloud is the broker i have followed this tutorials

https://imeter.club/topic/20

The MQQT broker is set but i am not receiving any data 

https://imeter.club/topic/20

This post shows you how to subscribe the data from mqtt-broker, not publish data to IAMMETER-broker.



They are totally different.



Please confirm what do you exactly want to do first

Hello i just need to subscribe to the broker but it has started working.

Please let me know which mqtt client have you used and give me some pics about the setting of the mqtt client.

Hello i just need to subscribe to the broker but it has started working.
Looks like you are new here. Register for free, learn and contribute.