Iammeter Android App "kwh" view

Team,

my assumption is if I click in Iammeter android app on the "kwh" button (marked with red circle below) it provides similar output like the desktop app  "Alt"+mark range function. As you see from screenshots below the fields are there but without value...(experience is the same with rotated mobile screen as well)  

Can you advise PLS if my understanding of this function in Android app is right and if it is, how could I get the requested data? (I attache to the bottom below as well what is in desktop app and what I expect to get from android app as well..) Thanks, Gabor

Thread Status
16
212
3
4
0

Sort replies by:

Hi:

"my assumption is if I click in Iammeter android app on the "kwh" button (marked with red circle below) it provides similar output like the desktop app  "Alt"+mark range function."

Yes, your understanding is absolutely correct.

I have just check this with our demo account like below ,


it will report the output correctly,like below.



I think the difference is that your data does not start from 0:00.



please try to select the valid data time range from the power value chart(there is no alt here ,so just need the press operation to choose the time range here)

Then the corresponding kWh range will be appear..

like below.

I just found out we have a video that shows this feature.

https://youtu.be/TSvHxCbsSe8

Thanks for your answer. I have selected a different time range, but got the same result. (PLS see below)

(I just zoom in to selected range and hit the "kwh button) 

I tried the DEMO system as well what you advised - I can attache screenshots if needed, but got the same - empty- result. Could it be a permission issue or do you have any other idea PLS?

I have just double-checked, all permissions(asked for storage only) is allowed - so this i not the reason....

To answer your possible questions in advance, what I have double-checked until now.... Reinstalled the app, rebooted my mobile (Samsung Android 11), only one possible permission is granted(storage), at DEMO version this function does not work on my mobile either, I have tried via Wifi and 4G as well(so no router setup cause the issue), installed the app on other mobile (Xiaomi) but have the same result.. - if you have any other idea, just share with me PLS... (the device is working well and I can get this info from desktop app, so nothing critical, but would be good to dig out what is behind.. :-)   Thanks Gabor

Hi:

It is so strange because the pics I provided above is also use the phone of XIAOMI .

Let me confirm,

You have logged in the demo account as I suggested and without any result even though you have selected the time range in the power chart, yes?

If it is convenient, please provide a video to let me confirm how do you operate in your phone (like this https://youtu.be/TSvHxCbsSe8)

Hi Team,

I have see the video you have shared and I believe I do the same... 

I have recorded what I am doing, have a look on that PLS and let me know PLS if I do something wrong

https://youtu.be/W8SUaPkHJ7g

I have recorded it on a loud place, -sorry for that- as no voice is added, just mute your speaker and noise won't disturb you,

In first part I show what I am doing with my Iammeter, the second part I do the same with the DEMO site.

I zoom in for the period I would like to see and hit the "kwh" button... - should I do something else PLS?


Thanks Gabor

Thanks for the video you provided.

Please try not to do the "zoom" operation before the time range selection and confirm whether the problem would still exist in this 

Hi Team,I have see the video you have shared and I believe I do the same... I have recorded what I am doing, have a look on that PLS and let me know PLS if I do something wronghttps://youtu.be/W8SUaPkHJ7gI have recorded it on a loud place, -sorry for that- as no voice is added, just mute your speaker and noise won't disturb you,In first part I show what I am doing with my Iammeter, the second part I do the same with the DEMO site.I zoom in for the period I would like to see and hit the

Hi Team, yes I did it already and did it based on your advise again now - still the same result.

Tried again on Xiaomi, and Samsung as well, permissions are granted. Tried via WiFi and 4G as well (just to avoid  possible wrong router setting), tried with today and with yesterday (full day) results as well -and  without (and with) zoom as well..

Is it not possible, that you and me are using different version of Iammeter app? I am using the latest update from 18 of December 2022... (Iammeter Home Energy Monitor -  DevicBit)

Thanks Gabor

Ok, thanks 

I have already forwarded this issue to my colleague and will reply to you next week.

Hi,

May I ask if you are using the dark mode, we think it is related to the dark mode. We have released an update to google play, you can wait for the store to update, or download the latest version from our official website. https://www.iammeter.com/downloads/IAMMETER.apk

Hi Team, yes I did it already and did it based on your advise again now - still the same result.Tried again on Xiaomi, and Samsung as well, permissions are granted. Tried via WiFi and 4G as well (just to avoid  possible wrong router setting), tried with today and with yesterday (full day) results as well -and  without (and with) zoom as well..Is it not possible, that you and me are using different version of Iammeter app? I am using the latest update from 18 of December 2022... (Iammet

Hi, no I am not using dark mode - just normal mode on both Xiaomi and Samsung.. (on the video I have attached above you can see on the very first picture and at the end as well.. (if I understood the question right..) 

If you have newer(or older) version of Iammeter app, I am glad to install and have a look if the issue exits  with those versions as well...  from android store I have the latest and have not found any other version there

Clear cache, clear data, reinstall restart, try on different  mobile and with different source(DEMO data) - the usual workarounds I know, I have tried already .

As this issue exists with both of your DEMO system and my System in your cloud (and as both Xiaomi and Samsung provides the same result - via router and outside router as well - ) and for you I assume is working, the only one I can think on is that we are using different version of iammeter app or we reach Iammater cloud via different tunnel.... (I am using the latest from android store) 

You could try to use the latest app via your mobile network as well just to be sure that external access is not limited..

If it is not the case and you are using the same app version like me - and you used earlier versions of your software as well - you could delete your cache and data and have a look if the new version will still work properly..

I have no other idea, but my IT knowledge far from developer level.. :-), regarding android especially. Just let me know PLS what should I try and will come back to you with the outcome...

Thanks

Gabor

Hi,

Because Google Play has its own version listing rules, please make sure that the IAMMETER app version you are using is 1.9.3, if not, you can quickly download it from here,https://www.iammeter.com/downloads/IAMMETER.apk

Hi, no I am not using dark mode - just normal mode on both Xiaomi and Samsung.. (on the video I have attached above you can see on the very first picture and at the end as well.. (if I understood the question right..) If you have newer(or older) version of Iammeter app, I am glad to install and have a look if the issue exits  with those versions as well...  from android store I have the latest and have not found any other version thereClear cache, clear data, reinstall restart, tr

Hi Team,

I just have seen that you have uploaded a new version of Iammeter to Google Store yesterday  - I have downloaded and installed it and I can confirm it works.. Thank you very much for your support, you are really fast and professional..!

Thanks Gabor

Looks like you are new here. Register for free, learn and contribute.