IAMMETER will not connect to AP with mixed mode WPA2/WPA3

In a previous topic it was advised that IAMMETER wifo only operates on WPA2, and that any AP's should be set to WPA2 WPA3 mixed mode.


I have tested wifi connectiion on 2 different AP's

  1. Unifi USG AP
  2. Fritzbox AP router

In both cases the IAMMETER will not succesfully connect to the AP, even though it appears in the list of available AP's in the Basic settings, unless the AP is set to WPA2 only.


This means that my AP security has to be "dumbed down" in order to allow the IAMMETER to connect.


Is there any way that this can be rectified?


Thread Status
2
30
2
2
0

Sort replies by:

Hi:

We have tested some routers, with WPA2 and WPA3 mixed mode, and it works correctly.

But we indeed do not test these two brands that your used.



I also do not know why it can not connect to these two brands' AP.

As you said," it appears in the list of available APs in the Basic setting,".

This is the most strange thing, if the AP is available in the list, it usually means that it is compatible.


By the way, in my opinion, if you use the mixed mode of WPA3 and WPA2, the security level is only decided by WPA2.
This is why I am not hurry to support WPA3.
Anyway, we decide to support WPA3 in our device in near future .
The develop work would be started at Feburay,and hope it could be completed soon.

Thank you.


Is WPA3 support a hardware issue or a firmware issue?

Looks like you are new here. Register for free, learn and contribute.