Hi, I have to change the IP of my IAMMeter, but I cannot find where to do this via app? 

Thread Status
8
59
3
3
1

Sort replies by:

You can enable or disable the dhcp setting in the app local mode(the mobile phone needs to be under the same wlan with the energy meter)

I disabled DHCP but forgot to put the IP settings.   How to restart the Meter in the Hotspot Mode ?


Thanks.

Let me elaborate the situation.   

In my house, there are 2 APs, i.e. AP-1 and AP-2.   The Meter was in the DHCP Mode, working properly.  I decided to make it a fixed IP, just disabling the DHCP button in the app.  The current IP number stayed the same, 192.168.1.49, and it rebooted fine attached to AP-1.


Then, I decided to switch to AP-2.   Once I selected AP-2 in the wifi setup page and pressed Save & Reboot.   Unfortunately, I didn't pay attention to the current IP shown, but it looked like 0.0.0.0.


So, the Meter rebooted with AP-2 and IP 0.0.0.0.  I guessed.   I can't find any IP in my home network to log into the Meter.  There is no iMeter_xxxxxx hotspot shown, even I turned off the power for a minute.

This is why we do recommend using the DHCP mode .
I guess your device are in this situation
1 it already connects to AP2 successfully, so the AP (ssid: iMeter_sn) do not appear. You can also confirm this by the status of the wifi led in the front panel.
2 the fixed IP (192.168.1.49) is not a valid IP under AP2. So you can not visit this IP under the network of AP2.

please follow this step.
1 power down AP2, then the SSID (iMeter_sn) would appear,
2 connect the SSID of the energy meter
3 do ipconfig or ifconfig(depends on your system), confirm the IP of your device and the IP of the energy meter (Regards to your description,it may still 192.168.1.49, this step is just a confirmation)
4 visit 192.168.1.49 by a web browser, configure the SSID and PWD to the AP1, and save.
5 power up AP2
6 configure the energy meter under AP1 network, enable dhcp firstly.
7 change ssid and pwd to the AP2, save
8 confirm the device had been connected to the AP2 and also can be accessed by the local IP of the AP2, then change the IP of energy meter to the fixed IP you wanted(disable DHCP, set the fixed IP)

Let me elaborate the situation.   In my house, there are 2 APs, i.e. AP-1 and AP-2.   The Meter was in the DHCP Mode, working properly.  I decided to make it a fixed IP, just disabling the DHCP button in the app.  The current IP number stayed the same, 192.168.1.49, and it rebooted fine attached to AP-1.Then, I decided to switch to AP-2.   Once I selected AP-2 in the wifi setup page and pressed Save & Reboot.   Unfortunately, I didn't pay at

You are right.  Thank you very much.

BTW, all IPs were reset to 0.0.0.0 after I changed the AP-1 to AP-2.  

0.0.0.0 is not accessible on any AP !!


This is why we do recommend using the DHCP mode .I guess your device are in this situation1 it already connects to AP2 successfully, so the AP (ssid: iMeter_sn) do not appear.  You can also confirm this by the status of the wifi led in the front panel.2 the fixed IP (192.168.1.49) is not a valid IP under AP2. So you can not visit this IP under the network of AP2.please follow this step.1 power down AP2, then the SSID (iMeter_sn) would appear, 2  connect the SSID of the energy meter3 do ipconfig

Hi

Have you resolved this problem now?

The IP display is just the IP in STA mode, not the IP in AP mode.

So,the "0.0.0.0" just indicates no IP had been allocated by the router.

For example:

when you do the first time configuration, you connect the SSID of iMeter_sn and visit the AP from HTTP://11.11.11.1 

when you log in the AP`s IP(11.11.11.1) successfully, you will find the IP will also display "0.0.0.0", but in fact, you had already visit the 11.11.11.1 successfully.

You are right.  Thank you very much.BTW, all IPs were reset to 0.0.0.0 after I changed the AP-1 to AP-2.  0.0.0.0 is not accessible on any AP !!

Yes, the problem has been solved.  Just turning off the connected AP and the iMeter will go back to the AP Mode again.

HiHave you resolved this problem now?The IP display is just the IP in STA mode, not the IP in AP mode.So,the "0.0.0.0" just indicates no IP had been allocated by the router.For example:when you do the first time configuration, you connect the SSID of iMeter_sn and visit the AP from HTTP://11.11.11.1 when you log in the AP`s IP(11.11.11.1) successfully, you will find the IP will also display "0.0.0.0", but in fact, you had already visit the 11.11.11.1 successfully.
Looks like you are new here. Register for free, learn and contribute.